Archives

Dear lazy web,

Anyone a wizard with Windows file sharing?

I have two Windows XP boxes on a wireless network. Call them A and B. I share a folder on A. On B, I copy a 7 MB file from A to B using Windows Explorer. The copy takes a few minutes, when it should take at most a few seconds.

I sometimes run a virtual machine, C, on computer A. The virtual machine runs Vista. Copying the same file to C from A also takes a few minutes, when it should be nearly instantaneous.

I've tried googling, but most of what I've found has to do with slowness getting the list of files in the shared folder. That part works fine. I've also found some problems with subtle incompatibilities between different versions of Windows, but A and B run the same version.

Copying from A to C is sometimes part of my debugging cycle. Having to wait a few minutes between testing each new version cuts significantly in to my productivity some days.

Share

4 comments to Dear lazy web,

  • Are you sure it’s the SMB portion and not something else confusingly stupid?

    Are there any noticeable delays when copying files from A to a USB drive, or from a USB drive onto B?

    I ask since I had one particular XP machine which developed an aversion to copies/deletes. It would spend minutes “preparing to copy files” and not making any obvious progress, then suddenly do the whole copy at once. This even happened when copying from the local hard drive to itself.

    I tried disabling various programs from running at bootup, turning off services, etc. I tried scanning for malware, viruses, etc. Nothing solved the issue. The machine is still totally responsive in the foreground while this is happening, and is able to start/run applications at full speed. I haven’t tried reformatting yet, but I intend to soon. For now, I just start deletes/copies and let them run in the background while I do other things.

  • Are you sure it’s the SMB portion and not something else confusingly stupid?

    I have developed a philosophy about debugging problems. If I everything I would normally assume to be true were actually true, the problem would not occur. Ergo, I assume nothing. :-)

    Are there any noticeable delays when copying files from A to a USB drive, or from a USB drive onto B?

    Nope.

    I ask since I had one particular XP machine which developed an aversion to copies/deletes. It would spend minutes “preparing to copy files” and not making any obvious progress, then suddenly do the whole copy at once. This even happened when copying from the local hard drive to itself.

    Vista is kind enough to provide a progress bar of the file copy progress. The bar does gradually move toward completion, so I suspect the problem is at least related to networking. Whether it’s an SMB problem, TCP problem, or link layer problem, I don’t know.

    I guess I should fire up a packet-sniffer and see what’s going on…

  • Have you generated a domain for authentication? If there’s not a generated trust, all the files use WINS with basic auth, and I recall that slows things down…

Leave a Reply